Home Home > GIT Browse > SLE12-SP4
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJiri Kosina <jkosina@suse.cz>2017-11-06 11:59:19 +0100
committerJiri Kosina <jkosina@suse.cz>2017-11-06 11:59:19 +0100
commit45613df8f2153574d1a88c1561458529a85c88b3 (patch)
tree3013054b3ec6a341a35d547d7ce7541926089520
parent28dd483e1c1255f0d47a2853740563b64fa59096 (diff)
rpm/kernel-binary.spec.in: add explicit dependency of kernel-*-devel onrpm-4.12.14-3--SLE-15-Packages-Beta2rpm-4.12.14-3
libelf-devel. Otherwise warning that got turned into error by e683952999 ("objtool: Upgrade libelf-devel warning to error...") would trigger and cause any packages being built against kernel-*-devel (such as KMPs, crash) not to have the libelf dependency included, and fail to build.
-rw-r--r--rpm/kernel-binary.spec.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/rpm/kernel-binary.spec.in b/rpm/kernel-binary.spec.in
index 6a9d37e9b0..06328fac7e 100644
--- a/rpm/kernel-binary.spec.in
+++ b/rpm/kernel-binary.spec.in
@@ -933,6 +933,8 @@ Requires: kernel-devel%variant = %version-%source_rel
Recommends: make
Recommends: gcc
Recommends: perl
+# for objtool
+Requires: libelf-devel
Supplements: packageand(%name:kernel-devel%variant)
%else
Requires: kernel-source-vanilla = %version-%source_rel