Home Home > GIT Browse > SLE15-AZURE
summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beulich <jbeulich@novell.com>2011-09-28 16:41:36 +0200
committerJan Beulich <jbeulich@novell.com>2011-09-28 16:41:36 +0200
commit50fb02f89fb521b257ce6a277a5024185d62ae4d (patch)
treee306b06c30831b1c012d6935298f6a56c94f0017
parentba0cfdcb4a536831694e3844d9ecdb3870506e6b (diff)
-rw-r--r--config/i386/xen19
-rw-r--r--config/x86_64/xen19
2 files changed, 26 insertions, 12 deletions
diff --git a/config/i386/xen b/config/i386/xen
index baa5ccf74b..fc3ab59105 100644
--- a/config/i386/xen
+++ b/config/i386/xen
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/i386 3.1.0-rc6 Kernel Configuration
+# Linux/i386 3.1.0-rc7 Kernel Configuration
#
# CONFIG_64BIT is not set
CONFIG_X86_32=y
@@ -4716,11 +4716,6 @@ CONFIG_XEN_NETDEV_BACKEND=m
CONFIG_XEN_NETDEV_TX_SHIFT=10
# CONFIG_XEN_NETDEV_PIPELINED_TRANSMITTER is not set
# CONFIG_XEN_NETDEV_LOOPBACK is not set
-CONFIG_XEN_PCIDEV_BACKEND=m
-CONFIG_XEN_PCIDEV_BACKEND_VPCI=y
-# CONFIG_XEN_PCIDEV_BACKEND_PASS is not set
-# CONFIG_XEN_PCIDEV_BACKEND_SLOT is not set
-# CONFIG_XEN_PCIDEV_BE_DEBUG is not set
CONFIG_XEN_TPMDEV_BACKEND=m
CONFIG_XEN_SCSI_BACKEND=m
CONFIG_XEN_USB_BACKEND=m
@@ -4760,6 +4755,18 @@ CONFIG_XEN_BALLOON=y
CONFIG_XEN_SCRUB_PAGES=y
CONFIG_XEN_DEV_EVTCHN=m
CONFIG_XEN_TMEM=y
+CONFIG_XEN_PCIDEV_BACKEND=m
+
+#
+# PCI Backend Mode
+#
+CONFIG_XEN_PCIDEV_BACKEND_VPCI=y
+CONFIG_XEN_PCIDEV_BACKEND_PASSTHROUGH=y
+CONFIG_XEN_PCIDEV_BACKEND_SLOT=y
+CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_VPCI=y
+# CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_PASSTHROUGH is not set
+# CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_SLOT is not set
+CONFIG_XEN_PCIDEV_BACKEND_DEFAULT="vpci"
CONFIG_STAGING=y
CONFIG_ET131X=m
# CONFIG_ET131X_DEBUG is not set
diff --git a/config/x86_64/xen b/config/x86_64/xen
index 1d7a01a070..40f1c2849a 100644
--- a/config/x86_64/xen
+++ b/config/x86_64/xen
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86_64 3.1.0-rc6 Kernel Configuration
+# Linux/x86_64 3.1.0-rc7 Kernel Configuration
#
CONFIG_64BIT=y
# CONFIG_X86_32 is not set
@@ -4649,11 +4649,6 @@ CONFIG_XEN_NETDEV_BACKEND=m
CONFIG_XEN_NETDEV_TX_SHIFT=10
# CONFIG_XEN_NETDEV_PIPELINED_TRANSMITTER is not set
# CONFIG_XEN_NETDEV_LOOPBACK is not set
-CONFIG_XEN_PCIDEV_BACKEND=m
-CONFIG_XEN_PCIDEV_BACKEND_VPCI=y
-# CONFIG_XEN_PCIDEV_BACKEND_PASS is not set
-# CONFIG_XEN_PCIDEV_BACKEND_SLOT is not set
-# CONFIG_XEN_PCIDEV_BE_DEBUG is not set
CONFIG_XEN_TPMDEV_BACKEND=m
CONFIG_XEN_SCSI_BACKEND=m
CONFIG_XEN_USB_BACKEND=m
@@ -4693,6 +4688,18 @@ CONFIG_XEN_BALLOON=y
CONFIG_XEN_SCRUB_PAGES=y
CONFIG_XEN_DEV_EVTCHN=m
CONFIG_XEN_TMEM=y
+CONFIG_XEN_PCIDEV_BACKEND=m
+
+#
+# PCI Backend Mode
+#
+CONFIG_XEN_PCIDEV_BACKEND_VPCI=y
+CONFIG_XEN_PCIDEV_BACKEND_PASSTHROUGH=y
+CONFIG_XEN_PCIDEV_BACKEND_SLOT=y
+CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_VPCI=y
+# CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_PASSTHROUGH is not set
+# CONFIG_XEN_PCIDEV_BACKEND_DEFAULT_SLOT is not set
+CONFIG_XEN_PCIDEV_BACKEND_DEFAULT="vpci"
CONFIG_STAGING=y
CONFIG_ET131X=m
# CONFIG_ET131X_DEBUG is not set